[E00000046] Error

There are 4 replies in this Thread. The last Post () by Craftato.

  • OK, so basically I'm constantly receiving the E00000046 error, and the reason seemingly changed from the first time I got it. There was a file it couldn't find in EXE2, and following what some people said worked for them, I restarted my PC. Now it seems to have no reason and turns out this error log.

    10:21:11.163 --> [i]:Prepare Crossfire Start

    10:21:11.164 --> [x]:Error Copy [E00000046]

    Additionally, this shows up on start-up and the launcher shows a bar eternally stuck at 0% that only goes up to 100% when I select either SP or MP. This didn't occur the first time I had this issue before I restarted my PC.

    10:19:59.047 --> [w]:2. Problem opening save file update.dat for download: Access is denied.

    No idea what to do here, so any help would be much appreciated. Crossfire installed perfectly fine, it's just it won't work when I try to boot up from the launcher.

  • Hello Craftato!


    According to this specification, E00000046 means folder access problems. Make sure that your Freelancer folder is not write-protected, you run the game as administrator, and your anti-virus software does not block anything there or, better, has this folder in exceptions list.


    Updates are not stuck at 0%, they just aren't dowloaded until you start the game. The only exception are updates to the launcher itself - that's what you saw the first time.


    P.S. After installing Crossfire, did you activate it in FLMM??


    HTH

  • I've checked off everything you've said and it still won't run, it isn't write-protected, ran it as administrator, checked the anti-virus. Also I did activate it before hand. Now it's pumping out the same error log as the first time.

    05:13:54.509 --> [i]:Launcher is updated...

    05:13:54.509 --> [x]:Error Launcher Update [E000001AB]

    05:14:07.348 --> [i]:Prepare Crossfire Start

    05:14:07.363 --> [w]:Could not copy file from C:/Users/Petros Karvounis/EXE/LauncherUpdater.exe to C:\Users\Petros Karvounis\EXE2/LauncherUpdater.exe

    05:14:08.140 --> [x]:Error Copy [E00000046]

    Not sure what I'm supposed to do from here because I can't find any folder called EXE2. Thanks for your help again.

  • why isnt your exe folder inside the freelancer folder?

    signew.jpg


    cfmoddblogo.png5904.png5904.png
    http://www.moddb.com/scripts/topsite.php?ts=4766


    Only dead fish swim with the stream.
    Don't discuss with idiots. They only drag you down to their level and then beat you with experience there.


    This is ten percent luck,
    Twenty percent skill,
    Fifteen percent concentrated power of will,
    Five percent pleasure,
    Fifty percent pain,
    And a hundred percent reason to remember the name!

  • Ngl, no idea man, seems like I had two EXE folders for Freelancer, one where it should have been and another in Users, which I just thought was meant to be there. The one in Users was completely empty bar the Launcher Update file, so I decided to go move that to the other EXE folder but it was already in there. Moving the User Launcher Update file did fix it though, so thank you for the help!