Crossfire 2.0 Client Edition 2.0.1

The 10th chapter of the famous Crossfire Freelancer mod. The nomad conflict was just the beginning. Years passed by, alliances formed and the enemy returned. The war has just begun. Discover sectors which have been unknown for mankind, until now.

The 10th chapter of the famous Crossfire Freelancer mod.

The nomad conflict was just the beginning.

Years passed by, alliances formed and the enemy returned. The war has just begun.


Discover sectors which have been unknown for mankind, until now.




INFO: latest installer version is from 05/2021!!! FLMM is no longer needed.


Please make backup of your save games prior using new intsaller!


NOTE: Please read info and technical details for latest addition to the mod (bonus mission). (Updated: 2020)

Images

  • cf22.jpg
  • Version 2.0.1

    The new and improved Crossfire 2.0 installer allows you to create a perfect and easy mod installation.

    It is highly advised to use this version.

  • Version 2.0

    Crossfire2.0 Setup


    Attention: This is an outdated version of the Crossfire Installer. Use version 2.0.1 instead.

    This old version will no longer work correctly.

  • Hi Forlon, i have a question. what is Freelancer game (vanilla) . is it the org, game cd or what.

    • yes, vanilla = original game

    • THANKS. ONE MORE QUESTION PLEASE. I have the old version on this cpu. if i install (crossfire 2.0 launcher files) will it update it. Also were do i install it.

    • I am not sure what you mean with old version.

    • before it stop working, with the server problen i am running 2.0 will it fix the old launcher. so it will update. i think you did the patch

      Crossfire 2.0 Launcher files

      SWAT_OP-R8R Nov 14th 2020

    • 2.0.1 is the latest version and it is required now

  • !!! New mod installer 2.0.1!


    Here I just want to shortly comment this new installer release:

    • For install is needed only Freelancer game (vanilla) installed (no mods, no patches)
    • FLMM is no longer needed!
    • Crossfire mod installation will not change vanilla Freelancer install!
    • Installer contains link to preview page where you can see how some settings will appear in game.


    Crossfire mod installation is now MUCH smoother and faster going and was tested working also on old windows versions back to Win XP.

  • Hallo,



    kann nicht downloaden, weil PC sagt: zip-File nicht lesbar.

    Versuche es morgen noch einmal.

    Grüße Blacky

    • Ich hatte vor 30mins das gleiche Problem. Werde mir das zeitnah mal anschauen.

      Bis dahin bitte den alternativen download verwenden: Freelancer 2.0: Crossfire file - Mod DB

    • hab das archive erst hiruntergeladen und entpackt, entpackt habe ich ein mal mit winrar und ein mal mit 7zip beide habe da das gleich angeben das dass archive beschädigt ist, habe eas dan von mod db heruntergeladen und entpackt das ging einwad frei das entpacken

    • Vermutlich nur ein packet loss während des Downloads. Die Dateien sind an sich identisch und der Upload auf Moddb erfolgte von der bereits hier online existierenden Datei (ging schneller).