[SOLVED] Windows 11 issue with USB 3.1 Gen2 port and clean W11 install

There are 4 replies in this Thread. The last Post () by Martind Forlon.

  • On my gaming PC build 3 years ago I installed this week Windows 11 ... I used simple OS update which went smooth, but as you may guess, there is some issue. For me it is about non-functional USB 3.1 Gen 2 port which was in windows 10 regularly working and I even used it for download W11 install files. Immediatelly after W11 installation/restart it stopped working. I contacted my MB manufacturer (MSI) and asked if there is any known issue. During emails exchange I used manual (ha, this was surprisingly a good idea :D ) and it helped me identify that non-working USB is Gen2 which I had no idea before. MSI also told me that they do not have drivers for this (ASMedia USB) and that it comes from Microsoft. They also told me that clean W11 installation on theirs side on the same motherboard (MSI Z370 TOMAHAWK) have that USB port correctly working. This leaves me 2(3) options: wait for update from microsoft (*technician suggested wait for few weeks since there should come some updates by his words) ... or go for clean W11 installation ... or ignore that issue (I can, but I do not want to :D).

    *Today I contacted local Microsoft office and asked technician if W7 key (there is older discuss about this here and here). will work if I used it for move from W7 to W10. He replied that it still is possible ... well I guess will find soon (later this week), if that info is reliable. I also saw on reddit that there also some other people have USB ports issues after W11 installation, but what I have read so far is mostly for general issues with USBs and not specific cases for one of USB versions.

    Any advices for this matter would be welcomed ... I'm not much happy with idea about reinstalling my whole gaming PC, but it can be possible better in long view and allows avoid any further issues with possible leftowers from W10.

  • Since when are USB drivers a ms resposibility?

    Thats something for the Mainboard manufacturer to provide.

    If your Mainboard has multiple USB connectors you can try to switch.

    It also can be that the Hardware broken... e.g. I am using USB Hubs for easy access reason but the high voltage on USB 3 meanwhile roasted 2 Hubs in the past 2-3 years.



    Only dead fish swim with the stream.
    Don't discuss with idiots. They only drag you down to their level and then beat you with experience there.

    This is ten percent luck,
    Twenty percent skill,
    Fifteen percent concentrated power of will,
    Five percent pleasure,
    Fifty percent pain,
    And a hundred percent reason to remember the name!

  • Quote

    From your image, it seems that this driver has not been installed successfully. This driver comes with the Microsoft system, we did not provide this ASMedia USB drive. We installed a clean Windows 11 OS on this motherboard, this driver can be installed normally and USB port can also work. How did you update the OS? Did you install the Windows 11 OS by USB drive or updated it in OS directly? Please manual update the driver in Device Manager for a try, can it work?

    hmm .. not sure what to say. MS technician told me too that USB drivers should be manufacturer responsibility ...

    If your Mainboard has multiple USB connectors you can try to switch.

    I have more USBs there which all are working. USB 3.1 Gen2 is only one port. Im still curious what is blocking update to this one. I suspect it could be one from utilities (vjoy) which I used for joystick curves finetuning, but this is just wild guess. I might use MS technician advice and wait little, I for sure want resolve it, but I do not need that port now, so it is not any critical problem.

    I used that port just before install W11, and right after installation it stopped working ... hardware issue is unlikely.

  • Sigh ... issue was ressolved, but I needed install W11 as new. Installation from USB to clean (formatted SSD) and old windows key from W7 were working. Still installing some things, it was not smoothly going operation. The worst problem for me was connection issue because iphone usb hotspot simpy did not worked for freshly installed W11 (but that's another story :) )

  • Martind Forlon

    Changed the title of the thread from “Windows 11 issue with USB 3.1 Gen2 port and clean W11 install” to “[SOLVED] Windows 11 issue with USB 3.1 Gen2 port and clean W11 install”.
  • And one more advice for anyone having issue with "stuck" on setting page (completion of Windows 11 setup) when is windows 11 freshly installed and you do not have working internet connection at that moment. Here is working way how to bypass internet connection check and re-estabilise it later. May come handy especially for those with Windows Home version.

    and few other technical details for Iphone USB hotspot users which use it for desktop connection to internet:

    • you will need actualised Itunes installed (need internet connection)
    • you need to have installed windows updates ... this also need working internet connection

    ... this above is kinda unsolvable issue, but I used my company andoroid phone (connected it through USB with my desktop PC and it worked) which I for data transfer connect to my personal iphone wifi hotspot. I like my iphone for its reliable services, but in these situations it may be really a pain.